New purchase - first impressions

Post Reply
garyd9
Posts: 26
Joined: Wed Sep 05, 2018 1:44 pm

New purchase - first impressions

Post by garyd9 » Fri Sep 28, 2018 9:41 am

Now that I've had my D300VS+ working (more or less) for a few days, I wanted to leave a post on my overall impressions, and perhaps some suggestions for further improvement. When reading this, please consider that my previous experience with Delta style printers is nil. In fact, my entire experience with 3D printing consists of an i3 clone that I had for a week before returning, and a flashforge creator pro that I've had for about a year (and rebuilt with a Duet controller.) Please keep in mind this lack of experience while reading.

My very first impression of the printer kit was that whoever packaged it was more OCD than I am. Everything in the box was well contained with nearly no risk of movement. There were dozens of little bags of screws, all divided into different parts of the build, and I really have to wonder how much time it took to count out the proper number of screws, nuts, etc for each bag. While building the printer, it was very easy to figure out where any given part might be located in the shipping box.

The parts included in the kit are, for the most part, of a high quality. The duet controller board is (in my opinion) the best possible choice for the job. Using a direct extruder instead of a bowden tube is also a good choice, though it does add weight to the effector. I did find some very minor inconsistencies in the SLS printed parts, but none of these caused any issue beyond having to scrape a bit of plastic/nylon before assembling. (For example, 2 of my carriages had very slightly smaller holes for jam nuts and bolts when compared to the 3rd carriage.)

I was aware (and I prepared, I thought) before I started assembly that there wasn't a proper build guide for the D300VS+. What I had to work with was an older guide for the non-plus model (since discontinued) and a few (incomplete) notes on the differences for the "plus" model. For the most part, the combined documentation was enough to complete the build, but there were a few areas where I had to seek extra information. Those included attaching the belts to the carriages, and setting up the "whip." Questions on the facebook group and reading the ultibots forum (when it was online) helped to resolve those issues.

This isn't to say there were no other issues. For example, the guides related to assembling the Titan Aero seem to reflect an inconsistency in what specific parts E3D might ship with their extruder. Some people get 35mm bolts and others don't. (This inconsistency isn't the fault of Ultibots: the Titan Aero is a sealed box from E3D.) With the kit as I received it, 35mm bolts were required to attach the heat sink, but weren't included. I was lucky to be able to source them from a local hardware store.

Related to the Titan Aero, I'd suggest that the D300VS+ effector assembly be modified in two ways (if possible.) First, it would be nice if the assembly allowed viewing the Titan's tension nut through the top of the effector. Several times already, I've found myself unsure if I had properly tensioned the extruder, so I'd loosen it completely just to tighten it again. Second, the part cooling fan on the current effector assembly completely blocks any access to the Titan's manual extrusion wheel/knob. I don't know if it would be feasible, but changing the effector design to move the part cooling fan to the left side of the extruder would allow access to the manual extrusion wheel. (On the other hand, there's probably a good reason it's not already on the left side - I just don't know what it is yet.)

As of this post, I still don't have my printer fully calibrated and running perfectly. I've only set the Z height offset for the center of the build plate (and limited myself to small prints) until I have a long-term home/table for the printer. (I believe that physically moving the printer around could impact the Z-height offsets.) I also have a tapping noise from the area of the extruder/nozzle that could be the result of backlash in the extruder or something else entirely. This tapping isn't a reflection on the printer kit, but more likely something that isn't adjusted or tweaked properly.

Overall, I'm really very happy with the kit.

Post Reply